Miner on a Raspberry Pi

I am trying to build my own Raspberry Pi hotspot. I got the RAK LoRa HAT and installed the packet forwarder. The documentation recommends running the miner on an EC2 instance.

I prefer running the miner on the Raspberry Pi if possible. Is it possible to run the miner on the Pi?

@yamanoorsai If you do find out how please share the steps. Although EC2 is free for a year I do see the point - what about after the free tier year expires? One has to pay for running the AMI at AWS indefinitely for as long as the minder needs to run

Yes. Instructions are available at https://developer.helium.com/hotspot/developer-setup#raspberry-pi-specific-setup

Edit: sorry, this is the wrong reference. I will need some time to dig up the right one. It might take a while :frowning: IIRC, the miner is 64-bit only, so you need to use a 64-bit os (raspbian is 32-bit only)

Here it is: https://developer.helium.com/blockchain/run-your-own-miner

1 Like

There is a 64 bit Raspbian in beta


I haven’t tried it myself yet but I’ve had good reports from others. Ubuntu 20 is what I reference in the docs though and we have tested that first hand.

@Louis what bare metal did you run the Ubuntu 20 miner on?

I tried the 64 bit Ubuntu install. It is going to need some work getting it up and running. I got the following error when I tried to issue the reset command:

../lora_gateway/reset_lgw.sh: 27: echo: echo: I/O error
../lora_gateway/reset_lgw.sh: 30: cannot create /sys/class/gpio/gpio7/direction: Directory nonexistent
../lora_gateway/reset_lgw.sh: 33: cannot create /sys/class/gpio/gpio7/value: Directory nonexistent
../lora_gateway/reset_lgw.sh: 34: cannot create /sys/class/gpio/gpio7/value: Directory nonexistent
../lora_gateway/reset_lgw.sh: 37: cannot create /sys/class/gpio/gpio7/direction: Directory nonexistent

While I can try and modify it to make sure that the gpio pins are controlled according to Ubuntu’s options, I am going to try the Raspbian 64 bit version. If that doesn’t work out, I am just going to use the Amazon EC2 instance.

It works with the Raspbian 64 bit architecture. I just need to verify that the gateway + miner launches at startup. Thanks for the tip @Louis

1 Like

@yamanoorsai when it’s all said and done, validated, etc would you post your setup with part numbers meaning which Pi runs the gateway, the miner and which RAK concentrator you used on your gateway build? Thank you

I am using the Pi4 with 8GB RAM. Miner - Arm 64 release, RAK concentrator - RAK2245

1 Like

@yamanoorsai cool - and how do you manage the gateway that you have built yourself? It doesn’t show up in the console, right? What web GUI is available to see the normal stats of a gateway such as challenges, connected clients, etc? Or is there none for the non-stock purchased devices? Thanks

I am only interested in transmitting sensor data to the gateway. Personally, I don’t care about the stats so long as it is running. I needed the gateway for a contest.

1 Like